Bold is Down: Error 502
Incident Report for Quintype
Resolved
This incident has been resolved.
Posted Nov 05, 2019 - 16:56 IST
Investigating
We are investigating this issue.
We will get back to you with the update shortly
Posted Nov 05, 2019 - 16:40 IST