Bold CMS is slow
Incident Report for Quintype
Resolved
This incident has been resolved.
Posted Jul 20, 2021 - 18:55 IST
Investigating
Our team is investigating the issue on high priority. We will update the status shortly.
Posted Jul 20, 2021 - 18:15 IST
This incident affected: Editor.